Subscribe / Unsubscribe Enewsletters | Login | Register

Pencil Banner

BLOG: Mountain Lion, Rosetta, and breath holding

Christopher Breen | Feb. 27, 2012
One of our readers, Karilyn Dammarell, looks to the future and isn't sure she likes what she sees.

One of our readers, Karilyn Dammarell, looks to the future and isn't sure she likes what she sees. She writes:

When Lion was released, it was announced that some programs wouldn't work with it--Quicken for Mac and some Adobe software, for example. So to install Lion, I had to get a new Quicken program and remove all of the other incompatible programs. I have family that chose to keep Snow Leopard because of this. Will they be able to use their Quicken 2007 software and other programs that were incompatible with Lion with the new Mountain Lion?

Regrettably, no. With Lion, Apple dropped Rosetta support--the technology that allows Intel Macs to run PowerPC applications. Quicken 2007 is one of those applications as is AppleWorks. Apple isn't a company that spends a lot of time thinking about the past nor does it change its mind (if one could ascribe mindfulness to a corporation) when it decides to abandon what it considers obsolete technologies.

If you're a Quicken 2007 user don't despair. Intuit has stated that it will issue a Lion-compatible version of the application, "available soon," according to Intuit. While this may seem like a half measure considering that Intuit is happy to update the Windows version of Quicken every year, it's better than a poke in the eye.

Speaking of pokes in the eye, you may want to take a gander at the Macs in the family inventory. Although Apple hasn't announced Mountain Lion's official system requirements, certain Macs that can run Lion can't use the Mountain Lion developer preview. They include:

        2006 iMacs
        Mid 2007 Mac mini
        2006 and 2007 Mac Pro
        2008 (original) MacBook Air
        Early 2008 and earlier MacBook
        2006 (15-inch and 17-inch) MacBook Pro
        2006 and 2008 Xserve

If it turns out that these Macs can't run the release version of Mountain Lion then your family's path is clear--or as clear as a dead-end can be. Stick with Snow Leopard and blissfully run your applications as you always have.

 

Sign up for MIS Asia eNewsletters.